Back to Top

Problem with HowStuffWorks

9 posts / 0 new
Last post
brianamyf
Offline
Last seen: 12 years 10 months ago
Joined: 02/21/2010 - 12:05
Problem with HowStuffWorks

I am a relatively new user, and have everything working except this particular Podcast

howstuffworks/podcasts/brainstuff.rss (or any other podcast from this site)

The podcast updates, goes into queue, downloads, shows the file and size, but will never play. Any ideas?? I have no problems with any podcast.

thanks

eric
Offline
Last seen: 2 years 10 months ago
Joined: 11/06/2008 - 22:02
Are you getting an error message?

Are you getting an error message? If so, please post it.

If not, you can send me the log (in the DC menu) right after you try to play it, and I'll check it out.

Thanks.

hsw
Offline
Last seen: 12 years 10 months ago
Joined: 04/06/2010 - 16:21
HSW Podcasts

I'll take another stab at getting our media department to correct their encoding problem. Can you please test some of the oldest episodes in the feed and see if those work?

At some point late last year, I manually re-encoded all of our podcasts using a better encoder (that should be android compatible), but it seems that we're still publishing new episodes using the non-compatible encoder.

Is there a free and/or limited version of DoggCatcher that I can install in an emulator or on my personal phone for testing?

eric
Offline
Last seen: 2 years 10 months ago
Joined: 11/06/2008 - 22:02
Access to DoggCatcher

I just send you an email with the details to get access to the market version of DoggCatcher.

What you need to do to get the older episodes to test is to set the 'number of items' to a big number. This will fetch the older items.

I spot checked an episode from 3 months ago (klepto) on things you should know and it worked ok.

Thanks for helping us out with this.

hsw
Offline
Last seen: 12 years 10 months ago
Joined: 04/06/2010 - 16:21
HSW Podcasts

I tested in the emulator on 2.1 and 1.5 as well as an actual HTC Eris running 1.5 and I couldn't reproduce the problem.

To the OP: can you please email sitesupport@howstuffworks.com and I can work with you to debug the issue?

edit: That goes for everyone else, too. If you're having trouble with our podcasts, please email us.

eric
Offline
Last seen: 2 years 10 months ago
Joined: 11/06/2008 - 22:02
Archos

This specific problem was occurring on an archos device which is running android 1.6. But since you tested on 1.5 and 2.1, and I doubt it's a problem that arrived and went away between 1.5 and 2.1, I would say it's likely something specific to archos. The symptom is what I saw before...a media player failure immediately after trying to seek.

I think one of my beta testers is using and archos device, I'll ask him to test that feed to see if he experiences the problem.

eric
Offline
Last seen: 2 years 10 months ago
Joined: 11/06/2008 - 22:02
Summary

So I've been working via email with brianamyf and hsw, both have been helping a lot.

What we found is that the android music player on the archos has trouble playing the hsw podcasts. The native archos player works fine though.

I've put brianamyf and hsw in contact with each other to see if they can resolve the problem.

brianamyf
Offline
Last seen: 12 years 10 months ago
Joined: 02/21/2010 - 12:05
No error message at all. I

No error message at all. I did find the mp3 on the hard drive and it played find in another media player with no problem. Sending log file. thanks

eric
Offline
Last seen: 2 years 10 months ago
Joined: 11/06/2008 - 22:02
Archos and howstuffworks

Ahhh, archos. The media files that come from that feed publisher aren't completely compatible with android. What happens for non-archos users is that the media files can start playing and they will play, but as soon as you try to seek or pause, the audio stops, or sometimes starts back at the beginning. Your log shows the android media player dying when trying to play those files. So it looks like the situation is a bit worse for archos devices. I don't think I'm going to be able to do anything to get those to play.

Have you tried playing them in the external player?

Here's a related post - http://www.snoggdoggler.com/node/467