Back to Top

Podcasts download when neither on Power nor on WiFi despite settings.

4 posts / 0 new
Last post
OutOfPhase
Offline
Last seen: 10 years 5 months ago
Joined: 01/19/2010 - 17:18
Podcasts download when neither on Power nor on WiFi despite settings.

Podcasts are being downloaded over the mobile network when they shouldn't be. I've observed this with 1.1.1156, not sure about the very latest version. It definitely happened in 1156 on Nexus One though despite it being supposedly fixed in that version.

It took me a while to realize what was going on. It started with unusual messages about "download failed after 5 tries". These popped up at odd times, even though I wasn't on power or wifi and my Settings said only download if on both. Then in the middle of last week I got a notification that a, quite small, podcast has been downloaded successfully. That was in the middle of the day, so I hadn't been on power/wifi for hours. However I couldn't be sure that the download hadn't started before I left home that morning, and simply finished much later.

But then on Friday I got a notification late in the afternoon that a new episode of a podcast was available. I immediately went to the download queue to see whether it was downloading and it didn't seem to be. There was a status bar message at the top saying that the phone was waiting as it wasn't on power. I was reassured and left it.

Then about 40 minutes later I got the phone out again and there was a notification to say it had successfully downloaded!

Between leaving the phone and checking again I had left work and traveled on an underground train where there is no phone reception, so perhaps that's significant in causing the bug to happen.

For me this is a bad bug as I could very easily go over my 3G bandwidth allowance. Video podcasts make this quite likely. To make sure I don't I've now turned off automatic checking for new podcasts, and run this manually instead when I'm on wifi.

eric
Offline
Last seen: 4 months 5 days ago
Joined: 11/06/2008 - 22:02
Downloads that shouldn't occur

Version 1156 did fix a specific case on only the nexus one where the device sometimes misreported whether or not it was on wifi. On the surface it looks the same as what you are describing because the end result is the same...a download starts that shouldn't.

What you describe has happened to me a small number of times and I've also heard a couple others report it but I never got to the bottom of it. You included a clue that it's pretty important that I didn't know was involved. You have both only on wifi AND only on power enabled and you are seeing the problem. That narrows down the problem a bit for me so now I know where to look.

I'll get some debug code around it and see if I can narrow down the cause.

The fix will get released to the beta testers first, so if you want to join the beta group to help test it, let me know.

Thanks for the detailed post, it helped me target the problem area.

I created an issue for this - http://mantis.snoggdoggler.com/view.php?id=420

eric
Offline
Last seen: 4 months 5 days ago
Joined: 11/06/2008 - 22:02
Nexus one downloads

I was able to reproduce the problem you described and have a fix. It will be in the next beta and should be in the next market release.

Thanks for helping me catch this one.

OutOfPhase
Offline
Last seen: 10 years 5 months ago
Joined: 01/19/2010 - 17:18
excellent news thanks

I'll download it and test it out, but it sounds as if you're confident. Thanks for the quick turn-around.