Back to Top

Auto progress to next podcast

12 posts / 0 new
Last post
dgoos
Offline
Last seen: 1 year 7 months ago
Joined: 01/12/2010 - 16:23
Auto progress to next podcast

Hello,

When I am running from battery power my podcasts do not auto progress to the next podcast. When one completes I must press a button on my phone to start the play of the next podcast. It seems like any button will work (volume up / down / Home / etc).

When I am plugged into power my podcasts will auto progress to the next podcast.

I've looked for a preference setting to override this behavior but I could not locate a preference to changes this behavior.

Thanks,
Darren

eric
Offline
Last seen: 2 years 3 months ago
Joined: 11/06/2008 - 22:02
Auto play

It sounds almost like the phone is going to sleep.

What type of devices is this? Also, are you saying that just pressing any button alone starts the play of the next podcast, does one of those keys awaken the phone and then you press play.

Could you please send the log (in the dc menu, send log) to support at snoggdoggler.com right after this happens (including when you get it playing again).

Thanks for posting.

dgoos
Offline
Last seen: 1 year 7 months ago
Joined: 01/12/2010 - 16:23
Auto play

This particular problem has gotten worse. Starting a week ago 2/19 my DC stopped auto progressing. Even when plugged into power it will not progress to the next podcast. Even long pressing the >>| button will not progress to the next podcast.

Log sent 3/1/2010 @ 4:10pm EST.

Thanks,
Darren

eric
Offline
Last seen: 2 years 3 months ago
Joined: 11/06/2008 - 22:02
I've got your log

Are you sure that auto-play is turned on? If it is the circular arrow button on the playlist screen will be green. If it's white then it's turned off.

I created another issue for this - http://mantis.snoggdoggler.com/view.php?id=423

I'll try to get a fix into the next beta.

dgoos
Offline
Last seen: 1 year 7 months ago
Joined: 01/12/2010 - 16:23
Auto play

Hello Eric,

I have the Sprint HTC Hero with Android 1.5. I typically press the volume buttons on the side of the phone to progress the podcast. This does not cause the phone screen to turn on but I can't say if this "wakes" the phone internally.

I am able to listen to music and the device does auto progress to the next song without any interaction from me.

I will send the log shortly.

Thanks,
Darren

tbeadle
Offline
Last seen: 11 years 1 week ago
Joined: 01/07/2010 - 21:51
Auto progress on error

My DROID phone seems to have playback errors when I plug in earphones (probably not a DC issue, related to the actual jack insertion or something). But it results in some bad DC behavior. When the playback error occurs, the "Auto" checkbox code causes the current podcast to be marked as done and in my case, deleted. Then the next queued podcast suffers the same fate, until all podcasts are marked as done and deleted. This is painful to recover from.

An odd side affect is that the "Music" app starts playing a song at random, in addition to playing about 1 - 2 seconds of each podcast before they are deleted.

The only luck I've had stopping the process is to crash the phone by pulling the battery.

eric
Offline
Last seen: 2 years 3 months ago
Joined: 11/06/2008 - 22:02
Headset plug

I get a lot of questions from people about weird behavior caused by headsets. I'll probably add something to the faq.

When headset cables or jacks start to fail, they tend to send rapid repeated false signals to the phone. Depending on what those signals are, it can cause a variety of things to happen. Do you have another headset you can try to see if you have a faulty headset?

What it sounds like is happening to you is this, but what isn't clear is why the 'mark as complete and play next' behavior is occurring. This shouldn't happen as a result of any headset events, only pressing the next button.

You could send the log (in the dc menu) when it's happening. I may be able to figure it out from that.

eric
Offline
Last seen: 2 years 3 months ago
Joined: 11/06/2008 - 22:02
Log file

If anyone is still experiencing this, please send me a log file. It's not happening for me but it seems to be affecting a few people.

Thanks.

dino
Offline
Last seen: 10 years 18 hours ago
Joined: 03/15/2010 - 05:08
same autoplay issue

Hi,

So this happens to me too and i don't know if any of this additional info is useful (though an issue has already been created).

Autoplay IS selected.
Happens when the phone enters its lockscreen (default is 1min). So the screen is off. If a podcast happens to finish during this time, it does not proceed to the next one until you push any button. You don't have to unlock the screen, but just a button press seems to wake up the OS enough for it to remember to move onto the next episode.

Sounds like a background scheduling issue, that the autoplay needs to keep awake in teh background while the phone enters power saving mode.

have been through all my android settings, so i hope it isn't something that i've accidentally switched off!

thanks.

eric
Offline
Last seen: 2 years 3 months ago
Joined: 11/06/2008 - 22:02
Lemme guess

Are you on a hero (or Eris)?

dino
Offline
Last seen: 10 years 18 hours ago
Joined: 03/15/2010 - 05:08
Hero. Stock OS, meaning 1.5.

Hero. Stock OS, meaning 1.5. Is that predictable?

eric
Offline
Last seen: 2 years 3 months ago
Joined: 11/06/2008 - 22:02
Hero - sleep

I've had at least 4-5 hero users experience this, and I don't think anyone that is not a hero user.

What's happening on the heroes is that they are going to sleep after an item finishes playing. All other devices stay awake. I even added some special code to try to prevent this sleep behavior but it seems like the device is ignoring the stay awake request.

If I ever can get my hands on a hero for a couple days I might be able to find a work around but that hasn't happened yet. I'll post if I make any progress.