Back to Top

Unable to download episodes from the "Unbelievable?" podcast feed

26 posts / 0 new
Last post
burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
Unable to download episodes from the "Unbelievable?" podcast feed

Here is the feed URL:
http://www.kaltura.com/api_v3/getFeed.php?partnerId=618072&feedId=1_jlj4...

Here are some sample podcast mp3 download URLs:
http://cdnapi.kaltura.com/p/618072/sp/61807200/playManifest/entryId/1_bn...
http://cdnapi.kaltura.com/p/618072/sp/61807200/playManifest/entryId/1_ii...
http://cdnapi.kaltura.com/p/618072/sp/61807200/playManifest/entryId/1_8o...

The error:
java.io.FileNotFoundException: /mnt/extSdCard/Android/data/com.QUERYARGS.clientTag=feed_1_jlj47tkv.snoggdoggler.android.applications.doggcatcher.v1_0/DoggCatcher/EpisodeEnclosures/38/a.mp3.PART: open failed: ENOENT (No such file or directory)

It looks like the question mark in the URL might be screwing up the download, since it seems to be inserting the portion of the URL after the question mark into the folder path (between "QUERYARGS." and ".snoggdoggler". There certainly isn't such a folder on my phone's file system.

WayneC
Offline
Last seen: 2 months 2 weeks ago
Joined: 02/23/2011 - 22:28
Feed Issue

What version of DC are you using? This problem was fixed in version 1.2.4054/1.2.3050 of DC http://mantis.doggcatcher.com/view.php?id=1883 - Currently I'm unable to reproduce this issue with the current version of DC.

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
I'm using the latest version

I am (and have been) using the latest version of DoggCatcher from the Play Store, and this is still an issue.
My current version is 1.2.5073

WayneC
Offline
Last seen: 2 months 2 weeks ago
Joined: 02/23/2011 - 22:28
What device are you using,

What device are you using, Kindle Fire or regular Android? If on Android device, are you storing DC media on internal or external storage?

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
Device info

Samsung Galaxy S4 with external storage, set to: /mnt/extSdCard/Android/data/com.snoggdoggler.android.applications.doggcatcher.v1_0
Running Android 4.4.4
(The latest OTA update from AT&T, from a few months ago. Not rooted or anything.)

WayneC
Offline
Last seen: 2 months 2 weeks ago
Joined: 02/23/2011 - 22:28
Repeat the steps to point DC

Repeat the steps to point DC to the new Android data location "http://www.doggcatcher.com/StorageDirectory" - (/storage/extSdCard/Android/Data/com.snoggdoggler.android.applications.doggcatcher.v1_0)
Then on the feeds screen long press on the "Unbelievable?" feed and also each feed with the storage error notification>press "Feed Options">Scroll down to “Feed storage directory” & press on the “Default” option.

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
Didn't change anything

I got the same error when attempting to download an episode.
I also tried checking the box to make filenames unique, but it was still unable to download the episode.

WayneC
Offline
Last seen: 2 months 2 weeks ago
Joined: 02/23/2011 - 22:28
The directory hasn't been

The directory hasn't been created for the feed, that's why I recommended that you repeat the steps to point DC to store media on the external drive & then checking the “Feed storage directory” for the "Unbelievable?" feed & press on the “Default” option

The 'make filenames unique' feature should be enabled because the "Unbelievable?" feed has an issue with duplicate file names.

If the files continue to fail, then the problem could be the SD card. Try another card & see if that resolves the issue.

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
Manually creating directory works

You are right that the directory didn't exist.

I wasn't able to get it to create the directory simply by pressing "Default" and then "OK". Pressing "Default" and "OK" didn't do anything, since it was already pointed at the default folder location.

However, I manually created the directory using a ES File Explorer. After that, downloads for that feed work normally.

So, why didn't it create the "38" directory in the first place?

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
I spoke too soon

I thought it fixed it, but it's not working anymore. The '38' directory exists (and contains a .nomedia file), but I get the same error when attempting to download new episodes.

This is the case whether or not I have the unique filenames box checked.

I don't think the problem is with my SD card, since every other feed I have works without issue. In any case, I don't have another card that would hold the amount of data that I store on my existing card (it's a 64GB card).

One other anomaly with this feed in DoggCatcher is that it shows the video icon on the feed items, despite the fact that they are mp3 files.

WayneC
Offline
Last seen: 2 months 2 weeks ago
Joined: 02/23/2011 - 22:28
I'm not sure why the

I'm not sure why the directory for the feed wasn't created, the next thing I would suggest is to delete the "Unbelievable?" feed & resubscribe to it again.

From the feeds screen>Long press on the feed & press "Delete Feed" - then resubscribe use the keyword "Unbelievable" listed first in DC's database.

The reason why there is video icon on the feed is because the publisher lists the file type as video (See below on the episode enclosure type="video/mp4) even though its audio file (mp3)

<enclosure url="http://cdnapi.kaltura.com/p/618072/sp/61807200/playManifest/entryId/1_bn... type="video/mp4"/>

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
Same old same old

It's doing the same things as before (only now 38 is replaced by 40, since I added another feed to see if it had the same issues--it didn't):
The feed directory doesn't get created automatically.
When I manually create the '40' directory, downloading episodes still fails in the same way.

This is frustrating. I've been dealing with this for a few weeks.

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
Thanks for your help!

Thanks for helping me identify the fix. I would hope that the root cause for this is identified and fixed, so that others don't experience the same frustration as I did. To that end, I can help with testing if desired.

WayneC
Offline
Last seen: 2 months 2 weeks ago
Joined: 02/23/2011 - 22:28
I don't know why this is

I don't know why this is happening, Eric (Developer) will respond later about this issue. Also send a log right after the feed fails to download (In the DC Menu>Report Problem)

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
I sent in a log

I did a force download that failed, and I sent in a log via e-mail.

eric
Offline
Last seen: 2 years 5 months ago
Joined: 11/06/2008 - 22:02
I got your log. I'm out of

I got your log. I'm out of town for a few more days, I'll check it out and soon as I get back home.

Thanks for helping us with this.

eric
Offline
Last seen: 2 years 5 months ago
Joined: 11/06/2008 - 22:02
Ok, so this bug is fixed,

Ok, so this bug is fixed, however you are on a very old version of the beta (5073), and this was fixed after that.

Can you go into the google play store and see if there is an update available. You version is over a year old.

Thanks.

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
How to exit testing group

I think my account might still be in the beta testing group. I remember I joined it to help test variable speed playback. I don't know how to un-join myself from that testing group. Any ideas?

eric
Offline
Last seen: 2 years 5 months ago
Joined: 11/06/2008 - 22:02
Do you remember joining the

Do you remember joining the beta by registering for a google group? If not, maybe that's why you haven't gotten any updates.

You can sign up for the current beta group and you should get updated to the latest beta...

www.doggcatcher.com/beta

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
Yes, I was a tester

I remember joining the testing group. I was a member of a Google group called doggcatcher-alpha, which doesn't exist anymore. I have just joined the doggcatcher-beta group, and become a beta tester. Hopefully that will allow me to update in a few hours. If it works, I will try the link to leave the tester group, and see if that lands me in the general population, or back in the nonexistent alphas.

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
That worked

I'm in the beta now, and I have v1.2.5155. It is able to download from the feed, or at least, the single item that it does load.
Strangely, it only loads a single item from the feed, and will not fetch more when I tap "Fetch more", even though the feed has plenty of items.

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
All feeds only show "new" items

I can only see items not marked as listened in all of my feeds. If I mark something as listened, it disappears completely from the UI, and I can't get it back.

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
Now using non-beta version

I exited the beta group and reinstalled the app from the play store. I have v1.2.4085, which I believe is the correct version.
I restored the configuration from backup.
I still can't see any episodes that are not 'new' on any of my feeds, even after I refresh or "Press to load more"

eric
Offline
Last seen: 2 years 5 months ago
Joined: 11/06/2008 - 22:02
Yep, that's the right version

Yep, that's the right version.

You are probably hiding done episodes. Press on one of your feeds, then press on the button at the top with two arrows...that shows/hides done episodes.

burndive
Offline
Last seen: 6 years 11 months ago
Joined: 10/16/2013 - 20:18
So it's a feature, not a bug?

I found the arrow, and that fixed it for all feeds. I think we can finally put this thread to bed.

eric
Offline
Last seen: 2 years 5 months ago
Joined: 11/06/2008 - 22:02
Great, glad we got it all

Great, glad we got it all sorted out.