Back to Top

Compatible with Android 2.0 (Eclair)?

3 posts / 0 new
Last post
waynemcg
Offline
Last seen: 10 years 11 months ago
Joined: 10/18/2009 - 22:58
Compatible with Android 2.0 (Eclair)?

Will the current version of DC run on the soon to be released Verizon Droid phone (running Android 2.0)? If not, when will a compatible version be available?

eric
Offline
Last seen: 5 months 3 weeks ago
Joined: 11/06/2008 - 22:02
Droid does (Eclair)

Typically (at least for 1.5 and 1.6), the development SDK is released at least a couple weeks before the OS ships or updates to physical phones. That gives devs a chance to do testing of their app to make sure they run on the new versions.

If the verizon phone is to be released in early Nov, then I would expect to see an SDK soon.

Once 2.0 (SDK) is released, I'll quickly do some testing and make whatever changes are necessary to support 2.0. I haven't had to make any changes in the past as android upgrades have been released, mostly because I don't use any non-standard android APIs.

There are a lot of people getting excited about the verizon device. As of this post, 'droid does' is number 3 on the google trends results...

http://www.google.com/trends/hottrends?q=droid+does&date=2009-10-18&sa=X

Thanks for the post.

eric
Offline
Last seen: 5 months 3 weeks ago
Joined: 11/06/2008 - 22:02
Android 2.0 (eclair)

I have done some testing with DoggCatcher on Android 2.0. There are a couple small changes that I need to make to maintain full compatibility. I'll be working on those for a bit, then a release with those changes will go to the beta testers in the next couple days. We should be all set for Verizon's Droid release.