Back to Top

MP4 podcasts with audio stream only show blank screen

13 posts / 0 new
Last post
grantonstar
Offline
Last seen: 8 years 11 months ago
Joined: 01/06/2013 - 07:56
MP4 podcasts with audio stream only show blank screen

Firstly, I'm a long time user (over two years). Doggcatcher is indispensible! Thankyou for your contstant updates and an excellent application.

My one query is with mp4 podcasts that contain no video stream, such as the AlJazeera Audio only examples at http://www.aljazeera.com/programmes/general/2008/09/2008915153339521328.... When these play the screen goes blank. It's not a major annoyance but is a problem as I primarily use Doggcatcher while exercising.

Is there any way to keep the UI while these are playing or alternatively update Doggcatcher to not show a blank screen if the mp4 contains only an audio stream?

eric
Offline
Last seen: 2 years 4 months ago
Joined: 11/06/2008 - 22:02
I'm not sure which podcast

I'm not sure which podcast you are subscribing to there, but the ones I saw have separate audio and video feeds. Are you sure you are using the audio feed?

If so, then DC is determining that it is video based on the file extension. I do have a bug to use the media type that the publisher defines, which will fix this.

Glad you're a fan, thanks for supporting the app.

grantonstar
Offline
Last seen: 8 years 11 months ago
Joined: 01/06/2013 - 07:56
If you look at the audio

If you look at the audio podcasts on that page, select any, it will show a blank screen when played in doggcatcher. I believe its because of the reason you said, mp4 implies a video file but there is no associated video stream in those audio only podcasts.

eric
Offline
Last seen: 2 years 4 months ago
Joined: 11/06/2008 - 22:02
That's exactly what's

That's exactly what's happening. I had a related bug that will fix this. I updated the bug to link back to this post so I can make sure the fix resolves this. I also moved it up in the schedule a bit.

Thanks for posting the problem.

http://mantis.snoggdoggler.com/view.php?id=1499

grantonstar
Offline
Last seen: 8 years 11 months ago
Joined: 01/06/2013 - 07:56
Excellent, thank-you!

Excellent, thank-you!

grantonstar
Offline
Last seen: 8 years 11 months ago
Joined: 01/06/2013 - 07:56
Is this fixed?

Sadly this is still not fixed :( playing back audio only MP4's leads to a blank screen and when the phones screen turns off or you navigate to a different app playback stops.

Let me know if you need any more info or assistance to help get to the solution.

eric
Offline
Last seen: 2 years 4 months ago
Joined: 11/06/2008 - 22:02
It should be with last

It should be with last night's release. Are you still seeing the problem?

grantonstar
Offline
Last seen: 8 years 11 months ago
Joined: 01/06/2013 - 07:56
Yes, still seeing the problem

Yes, still seeing the problem with the latest release.

eric
Offline
Last seen: 2 years 4 months ago
Joined: 11/06/2008 - 22:02
This is working for the feed

This is working for the feed I tested - http://feeds.aljazeera.net/podcasts/aljazeeraworldAU?format=xml

If you're having this problem with a different feed, please post the url and I'll check it out.

Thanks.

grantonstar
Offline
Last seen: 8 years 11 months ago
Joined: 01/06/2013 - 07:56
It works! I had to remove the

It works! I had to remove the feeds and re-add but after that its fine. A huge thankyou!

arnonsegal
Offline
Last seen: 9 years 5 months ago
Joined: 03/09/2013 - 03:40
I have the same problem

Hi I am using the last release, but I am using a virtual feed with MP4 files containing only audio
I still get a blank screen. Can you fix this for virtual feeds as well?

Thanks

eric
Offline
Last seen: 2 years 4 months ago
Joined: 11/06/2008 - 22:02
I don't think we are going to

I don't think we are going to be able to fix this for virtual. There isn't any way for use to know which type of media it is other than by looking at the extension. mp4 is used for both audio and video.

arnonsegal
Offline
Last seen: 9 years 5 months ago
Joined: 03/09/2013 - 03:40
Suggestion

Maybe enable when playing video streams to press "HOME" and keep the audio playing in the background?
Also, when the screen turns off?

You can have it optional. This way it will work for this kind of stream, even in virtual mode