Back to Top

Wrong encoding - German Umlauts are not displayed

9 posts / 0 new
Last post
Bear Knuckle
Offline
Last seen: 12 years 5 months ago
Joined: 08/03/2009 - 03:53
Wrong encoding - German Umlauts are not displayed

Hi,

I recently installed the DoggCatcher on my G1 and I like it so far, but in german texts the umlauts, like ä,ü,ö and the sz ß, are not displayed correctly. Seems like the Doggcatcher uses a encoding not capable of displaying these?

Greetings,

bK

eric
Offline
Last seen: 1 year 9 months ago
Joined: 11/06/2008 - 22:02
International chars

Can you please post the feed url and I'll take a look. Are you seeing the problem in the feed or items screen....or is it when viewing news articles?

If it's the news articles, I have already fixed a bug that will probably resolve it. The fix is not in the market version, the beta testers have it now though.

Thanks for the post.

Bear Knuckle
Offline
Last seen: 12 years 5 months ago
Joined: 08/03/2009 - 03:53
Hi eric, thanks for the fast

Hi eric,

thanks for the fast reply.

The problem occurs in every view of the feed. At the feed items screen and when reading a specific article.
One feed at which it occurs is: http://www.spiegel.de/schlagzeilen/index.rss
(you can try any spiegel.de feed).

Also I think, some or the articles are not recognized as "text". Doggcatcher tries to download the article, just to be not able "to play" it, and doggcatcher says "it seems not to be video/audio". Which of course it is not.

I don't know if theres a wrong configuration from spiegel.de or doggcatcher is wrong.

eric
Offline
Last seen: 1 year 9 months ago
Joined: 11/06/2008 - 22:02
Two questions

I have tested quite a few feeds with international characters and haven't had any problems in a many months. I am seeing the question marks instead of the international chars. I'll create an issue for this and look into it a little deeper.

http://mantis.snoggdoggler.com/view.php?id=183

As far as the non-text items, take a look at the feed you posted in your browser. There are links to images for some of the items. I have never seen a feed include images in that manner. They are tagged as enclosures, which is the way audio files normally are in podcasts. It may be valid to do this. If it is, I'll change DC so that I'll ignore enclosures if they are images. I'll also create an issue for this.

http://mantis.snoggdoggler.com/view.php?id=184

Thanks for posting.

DerKladower
Offline
Last seen: 11 years 11 months ago
Joined: 02/16/2010 - 08:23
Hi, I like to bring this once

Hi,

I like to bring this once more to your attention.
It would be nice to see the correct characters instead of questionmarks.

Thanks

BenoMueller
Offline
Last seen: 11 years 3 months ago
Joined: 10/24/2010 - 07:06
Once again ;-)

I would like to thank you for this great app. It's far better than its alternatives. But it would be even better if it could correctly deal with Umlauts (e.g. in the feed http://pod.drs.ch/kontext_mpx.xml). Thanks.

BenoMueller
Offline
Last seen: 11 years 3 months ago
Joined: 10/24/2010 - 07:06
Once again ;-)

I would like to thank you for this great app. It's far better than its alternatives. But it would be even better if it could correctly deal with Umlauts (e.g. in the feed http://pod.drs.ch/kontext_mpx.xml). Thanks.

FHanky
Offline
Last seen: 7 years 4 months ago
Joined: 10/24/2010 - 08:18
Hello, this problem also

Hello,

this problem also occurs when downloading and viewing the descripton from a podcast or an episode from a podcast.

Example: the description of http://rss.dw-world.de/xml/podcast_wirtschaft and its episodes is not correctly encoded

eric
Offline
Last seen: 1 year 9 months ago
Joined: 11/06/2008 - 22:02
Internal chars

Yep, that was recently reported also. I've got an issue for it - http://mantis.snoggdoggler.com/view.php?id=672

I'll add a reference to this post.

Thanks for posting.