Back to Top

After bluetooth headset disconnect, podcast resumes at the wrong time.

5 posts / 0 new
Last post
Loztblaz
Offline
Last seen: 7 years 8 months ago
Joined: 04/06/2011 - 23:16
After bluetooth headset disconnect, podcast resumes at the wrong time.

I'm on an AT&T Galaxy S3 (i747), running ICS 4.0.4, and the latest DC version. My issue is that when I turn off my bluetooth headset while listening to a podcast, when I try to resume playing, it starts back up at where I started listening the previous session. The odd part is that the seek bar shows the correct time, but the audio starts at the place where I started listening the session before. For example, if I started listening to a podcast at timestamp 10:00, listened for 20 minutes and turned off my headset, upon hitting play, the seek bar would show 30:00, but the audio that is playing would be from 10:00 in that episode.

I've been using DC with zero problems for close to two years, so I'm at a loss here.

edit: also, this behavior started happening once I bought a new phone, previously I was on an Atrix and it was working fine.

eric
Offline
Last seen: 2 years 3 months ago
Joined: 11/06/2008 - 22:02
That sounds like a problem

That sounds like a problem with the android media player, which is pretty strange since I would expect to be getting lots of posts if the s3 had a problem like that. I can verify if you send a log (in the dc menu) right after this happens, with a brief description of what you did just prior.

Since the seekbar is displaying the correct time, that means that DC remembers the correct time but the android media player just isn't seeking to the correct location.

You could try enabling one or both of the advanced preferences with 'hack' in the name. They work around resume/seekbar quirks on some devices. But if you do that, let's wait until after I check out the log.

Loztblaz
Offline
Last seen: 7 years 8 months ago
Joined: 04/06/2011 - 23:16
Thanks for the response. I

Thanks for the response. I emailed in a log right after having the issue happen. The first time I tried to replicate it, it didn't seem to happen unless I left the app after the headset disconnect, then entered it again before trying to play the podcast.

eric
Offline
Last seen: 2 years 3 months ago
Joined: 11/06/2008 - 22:02
That looks like a bug in the

That looks like a bug in the rom. We are just resuming a media player that has already been playing and paused an episode, but the player is mistakenly starting the audio playback from the beginning.

Here's the position DC remembered, that's about 15 minutes or so into the episode.

07-09 19:58:20.500 I/DoggCatcher( 1473): MediaPlayerController::PlayOrPause - [title: LeVar Burton position: 914342] - [157ms]

Loztblaz
Offline
Last seen: 7 years 8 months ago
Joined: 04/06/2011 - 23:16
Alright, thanks for the

Alright, thanks for the troubleshooting. I'll probably be using something other than the carrier rom soon anyway, so it's not a huge issue.

starix
Offline
Last seen: 9 years 9 months ago
Joined: 08/31/2012 - 03:18
Added a comment here: