Back to Top

Won't update feed unattended under certain conditions

5 posts / 0 new
Last post
teambob
Offline
Last seen: 10 years 6 months ago
Joined: 12/19/2011 - 17:27
Won't update feed unattended under certain conditions

Hi,

I love your product. I am just having a very annoying issue with it.

DETAILS:
DoggCatcher Version: 1.2.2919
Device: HTC Sensation
Android Build: 2.34
Carrier: Vodafone Australia

SUMMARY: Won't update feed unattended under certain conditions

STEPS TO REPRODUCE:
1. Restart phone
2. Ensure the phone is in range of a known wifi access point
3. Disable mobile data
4. Do not start Doggcatcher
5. Wait for time scheduled in Doggcatcher

OR

1. Start doggcatcher
2. Quit doggcatcher
3. Leave the range of a known wifi AP
4. Enter the range of a known wifi AP
5. *Do not touch the phone* - in particular do not awake it from sleep
6. Wait for the time scheduled in Doggcatcher

WHAT HAPPENS: The feed is not updated and no error is given. The download does not commence and no error is given.

WHAT SHOULD HAPPEN: The feeds should be updated then the relevant download should commence

FREQUENCY: It occurs quite consistently. I need to do all the workarounds to get doggcatcher to work. Typically I get the workarounds right about 3/4 of the time, so it is somewhat annoying.

SEVERITY: Normal

teambob
Offline
Last seen: 10 years 6 months ago
Joined: 12/19/2011 - 17:27
BTW here is one of the feeds

BTW here is one of the feeds that I am having trouble with: http://www.democracynow.org/podcast.xml

eric
Offline
Last seen: 2 years 3 months ago
Joined: 11/06/2008 - 22:02
So do you have the preference

So do you have the preference - "misc / start on boot" enabled?

If not, then I can definitely see why the first issue is happening. DC needs to start in order to register the android alarm that wakes it back up to update the feeds.

I also suspect that if you exit DC (which is actually killing itself), that will also remove the android alarm to wake it back up. I've never tested it but I can see how this might happen.

teambob
Offline
Last seen: 10 years 6 months ago
Joined: 12/19/2011 - 17:27
"Start on boot" was not

"Start on boot" was not enabled, perhaps that will solve the problem. Once DC has been run once there is no problem. I will monitor the situation and let you know.

I will do a bit more experimentation with the second problem (wifi) - in particular whether other apps are affected. I don't think they are but I need to nail it down.

Have you considered using the accounts & sync system like most mail, facebook, weather and news apps?

eric
Offline
Last seen: 2 years 3 months ago
Joined: 11/06/2008 - 22:02
Ok, sounds good. I thought I

Ok, sounds good.

I thought I already had an issue for the sync thing but I couldn't find it so I created one - http://mantis.snoggdoggler.com/view.php?id=1139