Back to Top

Seeking in ogg file does not work

10 posts / 0 new
Last post
danield
Offline
Last seen: 7 years 5 months ago
Joined: 02/17/2011 - 16:24
Seeking in ogg file does not work

In Doggcatcher 1.1.1904 on the Nexus S, seeking in an ogg file does not work.
In particular this one:
http://alternativlos.cdn.as250.net/alternativlos-14.ogg

When pressing the back button, the position actually moves forward instead of backwards!

Seeking when playing this file in the external media player however does work.

eric
Offline
Last seen: 1 week 22 hours ago
Joined: 11/06/2008 - 22:02
Feed url

Can you please post the feed url for the feed having that problem.

Thanks.

danield
Offline
Last seen: 7 years 5 months ago
Joined: 02/17/2011 - 16:24
The URL for the ogg feed is

The URL for the ogg feed is http://www.alternativlos.org/ogg.rss

eric
Offline
Last seen: 1 week 22 hours ago
Joined: 11/06/2008 - 22:02
Seeking fine for me

I'm using a nexus one (2.3) and seeking that file is working fine, anyone else having this problem?

danield
Offline
Last seen: 7 years 5 months ago
Joined: 02/17/2011 - 16:24
Still there

Hi,
I'm still having that problems with newer episodes from the same feed.
Since this is the only .ogg feed I'm subscribed to, I do not know whether this is a general problem with .ogg files or merely from that source.

However I want to add another detail: Although skipping back/forward jumps to wrong positions (skipping back actually skips forward (the position display seems to be correct)), seeking back and forth with the slider does actually work. (But it less precise for long podcasts)
So it appears as if seeking is only wrong when triggered through the << and >> buttons on these oggs.

Maybe they use some calculations to skip to a specific position which are wrong for those .oggs? (Because of variable bitrate or what not..)??

If you know any way I can assist in narrowing down that bug, please let me know.

Thanks.

eric
Offline
Last seen: 1 week 22 hours ago
Joined: 11/06/2008 - 22:02
DC uses an embedded android

DC uses an embedded android media player for audio playback. Can you try launching the audio file in the external player and see if you get the same problem there?

danield
Offline
Last seen: 7 years 5 months ago
Joined: 02/17/2011 - 16:24
Tried, then noticed that the

Tried, then noticed that the current android music player doesn't offer the functionality to skip forward/backward a few seconds by tapping >> or <<. It only skips track wise (tried ogg and mp3).
It also offers seeking by dragging the position slider of the current track, which works, but that did work with DC as well.
So I cannot reproduce the problem with the stock media player because it doesn't offer that particular function.

eric
Offline
Last seen: 1 week 22 hours ago
Joined: 11/06/2008 - 22:02
Yep, sorry for asking you to

Yep, sorry for asking you to do something that won't work, I forgot that those buttons were prev/next.

I'm able to see the same behavior that you are. That's got to be a problem with the android media player handling the encoding of the files.

There is an mp3 version of the same feed that most likely does not have the problem. You can search for it in the dc directory.

spamtree
Offline
Last seen: 2 years 2 months ago
Joined: 01/31/2018 - 18:25
I have the same problem with mp3.

Any solution to this problem. It stated occurring this month. Everything was fine before this month. Everything works fine with same file using VLC.

Thanks

WayneC
Offline
Last seen: 1 week 5 days ago
Joined: 02/23/2011 - 22:28
If your device is running 6.0

If your device is running 6.0+ and up try switching to Google’s Android experimental media player for 6.0+/7.0+/8.0+ devices...... (DC Navigation Menu>Settings>Advanced) Enable “Experimental Marshmallow media player”see FAQ post "Audio playback problems" under "Playback Issues" http://www.doggcatcher.com/AudioPlaybackProblems