Back to Top

Partial Download Problem

7 posts / 0 new
Last post
elenaran
Offline
Last seen: 13 years 11 months ago
Joined: 02/06/2009 - 17:09
Partial Download Problem

Lately, when I download podcasts from NPR's Radiolab, it downloads 100%, but DoggCatcher still shows the files as being partial. I can play the files if I long press and select "Play Partial(!)", but it would be nice if this could be fixed so I can play the files with just a single click. The podcast is here:

http://feeds.wnyc.org/radiolab

eric
Offline
Last seen: 2 years 10 months ago
Joined: 11/06/2008 - 22:02
Partials

I tried downloading a couple episodes and none are partials. Which episodes are you having this problem with.

As a side note, take a look at this thread, we'll be changing the default action for partials exactly as you request - http://www.snoggdoggler.com/?q=node/105.

elenaran
Offline
Last seen: 13 years 11 months ago
Joined: 02/06/2009 - 17:09
try "Sperm Tales" from 06 Oct

try "Sperm Tales" from 06 Oct 2008 - i've tried this one multiple times and it always says it's partial even though it gets 100%

thanks for the update

eric
Offline
Last seen: 2 years 10 months ago
Joined: 11/06/2008 - 22:02
Wrong size

That episode misreports the size. Just play the partial, it should play just fine.

elenaran
Offline
Last seen: 13 years 11 months ago
Joined: 02/06/2009 - 17:09
thanks

thanks

PSU Jeep
Offline
Last seen: 13 years 5 months ago
Joined: 08/09/2009 - 00:11
Keith and the girl partial downloads

I picked up DoggCatcher for two podcasts - Hardcore History and Keith and the Girl. Hardcare History works great, however, the Keith and the Girl podcast has only worked once. Every other time I've tried to download episodes I get a partial download.

Can you take a look or recommend a work around? Thanks.

Feed: http://www.KeithAndTheGirl.com/RSS

eric
Offline
Last seen: 2 years 10 months ago
Joined: 11/06/2008 - 22:02
Partials

What I would recommend downloading the items and then look inside the feed xml (length is the attribute we're looking for). Most likely what is happening is that the publisher is reporting the size to be one value but the real size is smaller.

Another way of testing this is to simply play the media. If it shows as a partial but it successfully plays all the way to the end, then it has the cause I just described.

I do have an issue scheduled to workaround this problem. I'll do my best to get it into one of the next few releases.

Thanks for posting.